Back to overview
MachShip is experiencing technical issues
Dec 07 at 05:21am AEDT
Affected services
MachShip Live API
Resolved
Dec 07 at 05:22am AEDT
MachShip is currently experiencing technical issue and the team are working towards regaining services. All services have now been restored
Affected services
Created
Dec 07 at 05:21am AEDT
All systems were restored and operating as normal at 5:21am ADST
Affected services