Back to overview
Degraded
Capital Transport Pricing
Feb 18 at 09:06am AEDT
Affected services
MachShip Carriers
Resolved
Feb 18 at 09:24am AEDT
This incident has now been resolved,
Affected services
MachShip Carriers
Created
Feb 18 at 09:06am AEDT
There is currently an issue that is effecting pricing returning for Capital Transport jobs in MachShip
This is being looked at with a high priority.
MachShip will provide updates as they return
Affected services
MachShip Carriers