Back to overview
Degraded

Issues Logging into MachShip

Mar 14, 2021 at 8:17pm UTC
Affected services
MachShip Live API
MachShip Carriers
FusedShip

Resolved
Mar 14, 2021 at 8:24pm UTC

This issue should now be resolved.

If you are facing issues logging please refresh the page on your browser and log in.

If you still face issues please contact support@machship.com

Updated
Mar 14, 2021 at 8:21pm UTC

This issue should now be resolved.

If you are facing issues logging please refresh the page on your browser and log in.

If you still face issues please contact support@machship.com

Created
Mar 14, 2021 at 8:17pm UTC

There is currently an issue users will be facing logging into MachShip

This is being looked at with the highest of priorities