MachShip Login Issues
Resolved
Mar 16 at 10:30am AEDT
A few weeks ago, we changed the way logging into MachShip worked such that it would go via Microsoft's Azure Active Directory system, in the hope that we would be able to provide a more secure and modern login experience, by moving this responsibility off to a dedicated login system.
As we have seen today, that login system has just failed for many millions of people across the world, and unfortunately, whilst MachShip was still 'up and running' in the background, the outage of the Azure system prevented many people from being able to log in.
We will be reviewing this implementation over the coming weeks to come up with a way to ensure this has some level of redundancy which would allow our users to still log in if and when the Azure system has an outage.
We apologise for the inconvenience this has caused to our users, and will keep you updated as to our plans for redundancy for the login system.
Affected services
Updated
Mar 16 at 10:30am AEDT
A few weeks ago, we changed the way logging into MachShip worked such that it would go via Microsoft's Azure Active Directory system, in the hope that we would be able to provide a more secure and modern login experience, by moving this responsibility off to a dedicated login system.
As we have seen today, that login system has just failed for many millions of people across the world, and unfortunately, whilst MachShip was still 'up and running' in the background, the outage of the Azure system prevented many people from being able to log in.
We will be reviewing this implementation over the coming weeks to come up with a way to ensure this has some level of redundancy which would allow our users to still log in if and when the Azure system has an outage.
We apologise for the inconvenience this has caused to our users, and will keep you updated as to our plans for redundancy for the login system.
Affected services
Updated
Mar 16 at 10:28am AEDT
MachShip is no longer experiencing issues with logging in as Microsoft have resolved their issue
Affected services
Updated
Mar 16 at 08:53am AEDT
Microsoft's Active Directory services are coming online and some users are now able to authenticate and login in MachShip. Microsoft's fix is currently being rolled out so please be patient if you are still experiencing issues
Affected services
Updated
Mar 16 at 08:28am AEDT
Latest Update from Microsoft:
SUMMARY OF IMPACT: Starting at approximately 19:15 UTC on 15 Mar 2021, a subset of customers may experience issues authenticating into Microsoft services, including Microsoft Teams, Office and/or Dynamics, Xbox Live, and the Azure Portal.
CURRENT STATUS: Engineering teams are currently rolling out mitigation worldwide. Customers should begin seeing recovery at this time, with full mitigation expected within 60 minutes.
MachShip will continue to update clients as information becomes available
Affected services
Updated
Mar 16 at 07:48am AEDT
MachShip utilises Microsoft's Azure Active Directory as the underlying platform for authentication and logging in for enhanced security. In the last hour, we have reports from Microsoft that this platform is experiencing issues which is affecting some users from authenticating and accessing MachShip. This issue is not isolated to MachShip and is impacting Microsoft across the globe across all their products. Microsoft have their team of engineers looking to rectify the issue. We will continue to post updates here as we get them.
Microsoft Azure's status page is available here https://status.azure.com/en-au/status which can also be followed for live updates. At this stage we do not have an ETA as we are waiting on Microsoft's engineers to resolve the issue but we will post updates with news as we receive updates
Affected services
Created
Mar 16 at 07:35am AEDT
We are currently investigating issues with our login provider (Microsoft Azure Active Directory) that is preventing some users from logging in.
Affected services