Issues returning Routes / Pricing
Resolved
Apr 23 at 02:33pm AEST
Yesterday between 12:48pm AEST and 12:59pm AEST, routes and pricing were not returning for a brief period. The underlying cause was a cache that contains zone and location data was not able to properly retrieve information to correctly gather prices. Upon our investigation, this cache became ineffective due to a bad cache refill. We have added some additional checks and balances around the refill stage to help prevent this issue moving forward. Our development team believes this to be an edge case and we will continue to monitor and prevent this issue from occurring
Affected services
MachShip Live API
Updated
Apr 23 at 11:15am AEST
Yesterday between 12:48pm AEST and 12:59pm AEST, routes and pricing were not returning for a brief period. The underlying cause was a cache that contains zone and location data was not able to properly retrieve information to correctly gather prices. Upon our investigation, this cache became ineffective due to a bad cache refill. We have added some additional checks and balances around the refill stage to help prevent this issue moving forward. Our development team believes this to be an edge case and we will continue to monitor and prevent this issue from occurring
Affected services
FusedShip
MachShip Carriers
MachShip Live API
Updated
Apr 23 at 11:15am AEST
Pricing and Routing has remained stable over the past 24 hours. We will continue to monitor the issue
Affected services
MachShip Live API
Updated
Apr 22 at 01:01pm AEST
Pricing will now be returning for clients in MachShip
Affected services
MachShip Live API
Created
Apr 22 at 12:57pm AEST
Currently, there is an issue returning pricing to the MachShip platform.
This is being looked at with the highest of priorities
Affected services
MachShip Live API