Back to overview
Degraded

MachShip Issues

Nov 17 at 11:29am AEDT
Affected services
MachShip Live API
MachShip Carriers
FusedShip

Resolved
Nov 18 at 06:24pm AEDT

This issue was caused by MachShip’s login reliance on an Azure product called Azure Active Directory B2C which became unavailable for a few hours yesterday due to some upstream technical issues on Microsoft’s side. Azure Active Directory B2C was introduced to the MachShip platform earlier this year to help continually improve security and user management within the MachShip platform. Since rollout, we have experienced a handful of outages caused by this product and we are actively looking for viable alternatives and redundancies to mitigate this issue.

During the outage yesterday, all users that access the system via the User Interface and the login page were affected, and the outage caused users to be unable to login to the platform. During this time, all integrated users and systems (for example API integrations and automated file imports) were unaffected and continued to connect to MachShip successfully. This issue was caused and resolved exclusively by Microsoft and we were in constant communication with Microsoft until the issue was resolved.

Updated
Nov 18 at 06:02pm AEDT

This issue was caused by MachShip’s login reliance on an Azure product called Azure Active Directory B2C which became unavailable for a few hours yesterday due to some upstream technical issues on Microsoft’s side. Azure Active Directory B2C was introduced to the MachShip platform earlier this year to help continually improve security and user management within the MachShip platform. Since rollout, we have experienced a handful of outages caused by this product and we are actively looking for viable alternatives and redundancies to mitigate this issue.

During the outage yesterday, all users that access the system via the User Interface and the login page were affected, and the outage caused users to be unable to login to the platform. During this time, all integrated users and systems (for example API integrations and automated file imports) were unaffected and continued to connect to MachShip successfully. This issue was caused and resolved exclusively by Microsoft and we were in constant communication with Microsoft until the issue was resolved.

Updated
Nov 18 at 11:31am AEDT

This incident has been resolved.

Updated
Nov 17 at 02:48pm AEDT

We are experiencing consistent successful logins again via Azure B2C. We are continuing to monitor for any further issues

Updated
Nov 17 at 01:58pm AEDT

Microsoft have provided an update via their official status page showing that Azure Active Directory B2C services are facing issues:
https://status.azure.com/en-au/status

We will continue to keep you updated with how the issue is progressing

Updated
Nov 17 at 01:12pm AEDT

We have confirmation from Microsoft Azure that this is a problem on their end and their team of engineers are working on rectifying the issue as soon as possible. We will continue to provide updates as we receive them

Updated
Nov 17 at 12:30pm AEDT

Users may sporadically be able to login to the platform but the MachShip Team are continuing to work through these issue with Microsoft and we will continue to update you as more information comes available

Updated
Nov 17 at 11:52am AEDT

We have identified a connection issue in Microsoft's Azure B2C product which is what MachShip uses to authenticate and login users. We are in contact with Microsoft, however this appears to be an issue with the Azure B2C product that is not isolated to MachShip. We will keep you updated. This is affecting users that are logging into the system, API users / integrations authenticating with API tokens should not be affected by this Azure B2C outage

Updated
Nov 17 at 11:35am AEDT

This issue is still being investigated with the highest of priorities

Created
Nov 17 at 11:29am AEDT

The MachShip team are currently investigating issues in performance of the MachShip platform we will advise asap