Back to overview
Degraded

TNT Pickup Ex Brisbane

Feb 03 at 10:05am AEDT
Affected services
MachShip Carriers

Resolved
Mar 03 at 07:17am AEDT

This incident has been resolved.

Updated
Mar 03 at 07:17am AEDT

We are continuing to work on a fix for this issue.

Updated
Feb 15 at 05:02pm AEDT

We are continuing to work on a fix for this issue.

Created
Feb 03 at 10:05am AEDT

Carrier Update:
Due to COVID-19 outbreaks in Australia, some services have been impacted, especially those in the Brisbane metro region.
Please kindly arrange your shipment on the next available business day.
However, please note Time Critical services will remain available 24/7.