Back to overview
Degraded

MachShip Slowness

Mar 04 at 11:31am AEDT
Affected services
MachShip Live API
MachShip Carriers
FusedShip

Resolved
Mar 07 at 09:45am AEDT

What happened?

On Friday MachShip experienced some slow down within the pricing component of the system. During this time some users were experiencing slower than normal responses to pricing and create consignment requests.

How it was fixed?

The source of the issue has been traced down to additional load on the system and specific sub components that were not scaling with this additional load.

How we prevent it in the future

To address this issue, we have reconfigured parts of these subcomponents which has rectified the issue and long term we are in the process of rewriting components of the pricing engine to allow us to continue to scale into the future.

Updated
Mar 07 at 09:44am AEDT

What happened?

On Friday MachShip experienced some slow down within the pricing component of the system. During this time some users were experiencing slower than normal responses to pricing and create consignment requests.

How it was fixed?

The source of the issue has been traced down to additional load on the system and specific sub components that were not scaling with this additional load.

How we prevent it in the future

To address this issue, we have reconfigured parts of these subcomponents which has rectified the issue and long term we are in the process of rewriting components of the pricing engine to allow us to continue to scale into the future.

Updated
Mar 04 at 03:51pm AEDT

This incident has been resolved.

Updated
Mar 04 at 12:33pm AEDT

A fix has been implimented and the team are monitoring the results

System stability should be returned at this stage

Created
Mar 04 at 11:31am AEDT

Currently, the slowness being reported in MachShip is being investigated with a high level of urgency by the team.

We will advise as more information becomes available