Back to overview
Degraded
CTI Xpress - Server Outage
Jun 20 at 08:58am AEST
Affected services
MachShip Carriers
Resolved
Jun 20 at 11:56am AEST
This has been fixed by CTI
Affected services
MachShip Carriers
Created
Jun 20 at 08:58am AEST
Currently, CTI Xpress is experiencing a server outage.
This will be preventing clients from obtaining quotes and manifesting with CTI Xpress.
The CTI team are currently investigating this and will advise once rectified
Affected services
MachShip Carriers