Back to overview
Degraded
Xpress To You - Pricing, Tracking and Booking
Sep 20 at 02:02pm AEST
Affected services
MachShip Carriers
Resolved
Sep 20 at 03:48pm AEST
This incident has been resolved.
Affected services
MachShip Carriers
Updated
Sep 20 at 03:15pm AEST
Xpress to You has fixed this issue and pricing will now be returning
Affected services
MachShip Carriers
Created
Sep 20 at 02:02pm AEST
Currently, Carrier Xpress to You is experiencing issues with their systems that is preventing successful pricing, tracking and booking requests from being made.
A ticket has been lodged with their team to review.
MachShip will advise as information is made available
Affected services
MachShip Carriers