Back to overview
Degraded

FusedShip issues

Jul 19 at 12:44pm AEST
Affected services
MachShip Live API
MachShip Carriers
FusedShip

Resolved
Jul 19 at 02:28pm AEST

The cause of this outage was the release of a new platform to our integrations engine FusedShip.

Specifically, a library used by our core FusedShip engine and this newly released platform was updated during the release process.

This updated library auto-triggered a cascade of updates on some related libraries that were not triggered during testing in our staging change release.

While we would typically roll back in this situation, due to the number of libraries updated, it was deemed faster to upgrade our server to match the requirements of these libraries, which took some time to execute.

We apologise for the inconvenience.

Updated
Jul 19 at 02:27pm AEST

The cause of this outage was the release of a new platform to our integrations engine FusedShip.

Specifically, a library used by our core FusedShip engine and this newly released platform was updated during the release process.

This updated library auto-triggered a cascade of updates on some related libraries that were not triggered during testing in our staging change release.

While we would typically roll back in this situation, due to the number of libraries updated, it was deemed faster to upgrade our server to match the requirements of these libraries, which took some time to execute.

We apologise for the inconvenience.

Updated
Jul 19 at 02:27pm AEST

This incident has been resolved.

Updated
Jul 19 at 01:34pm AEST

The FusedShip team have now corrected all issues. A bulk back sync is being run again and orders will begin to flow through shortly

Updated
Jul 19 at 01:24pm AEST

The team are continuing to investigate the slowdown in orders and consignments flowing through, we will continue to update as information is available

Updated
Jul 19 at 12:59pm AEST

Issue has been identified and the records that were stuck are in the process of being re-pushed to MachShip

Created
Jul 19 at 12:44pm AEST

Machship is currently investigating an issue in the integrations middleware FusedShip

Orders will currently be failing to move into MachShip

This is being reviewed with a high priority and we will advise on a fix as soon as possible