Back to overview
Degraded

FusedShip - Errors Updating shipping platforms

Jul 20 at 11:08am AEST
Affected services
MachShip Live API
MachShip Carriers
FusedShip

Resolved
Jul 21 at 09:21am AEST

The issue related to the speed and reliability of our integration layer pushing updates back to clients' integration platforms.

When clients were pushing batches of jobs through our middleware layer, we queue the updates that go back to the system to ensure we do not hit any API limits that are in place with the platform. The issue related to these queue locks not being released in a timely manner, so jobs were being blocked from being updated for a period of time by other update jobs.

The issue was trigger by a recent upgrade to the integration layer and is now fully operational.

Future releases will undergo additional simulated load testing to ensure a similar issue does not occur moving forward

Updated
Jul 21 at 09:06am AEST

The issue related to the speed and reliability of our integration layer pushing updates back to clients' integration platforms.

When clients were pushing batches of jobs through our middleware layer, we queue the updates that go back to the system to ensure we do not hit any API limits that are in place with the platform. The issue related to these queue locks not being released in a timely manner, so jobs were being blocked from being updated for a period of time by other update jobs.

The issue was trigger by a recent upgrade to the integration layer and is now fully operational.

Future releases will undergo additional simulated load testing to ensure a similar issue does not occur moving forward

Updated
Jul 21 at 09:01am AEST

This issue has now been resolved and we have returned to stability in updating from the FusedShip platform

Updated
Jul 20 at 02:30pm AEST

The reliability of the updating has returned. The team is continuing to investigate and monitor

Created
Jul 20 at 11:08am AEST

Currently, there is an issue with the FusedShip platform undertaking some bulk updates to shipping platforms with data

This will not be affecting all integrations only those where bulk updates are undertaken

The team are investigating a fix for this at the moment and will advise