Back to overview
Degraded
Capital Transport Pricing Issues
Jan 28 at 09:36am AEDT
Affected services
MachShip Carriers
Resolved
Jan 28 at 09:48am AEDT
Pricing should now be returning for Capital
Affected services
MachShip Carriers
Created
Jan 28 at 09:36am AEDT
Currently, Capital Transport is experiencing some issues returning pricing - MachShip has contacted Capital, and the issue is in the process of being resolved
Affected services
MachShip Carriers